Hoppa till innehåll

Sökresultat Sökningen pågår Sökresultaten dyker upp här efterhand. Du kan fortsätta skriva om du vill begränsa sökningen.
Söker efter filmer
Söker efter produktkategorier
Söker efter användare
Söker efter gallerier
Sök forumtrådar
Stäng

ComHems kanalomläggning

17 svar i tråden

#1

Skickat 03 mars 2012 - 00:27

Någon som kör DVB-C kort och har ComHem?
Hur fungerar det för er nu när ComHem lägger om kanalerna?

Efter kanalomläggningen hittar jag bara 40 kanaler (i Borås). Bla så är TV6 borta för mig nu. Hittar ni alla kanaler och i så fall hur har ni sökt?

Jag har provat att söka med MythTV, scan, w_scan och jag tycker alla ger lite olika resultat.

#2

Skickat 04 mars 2012 - 09:38

Hejsan.
Vet inte hur det fungerar i MythTV, själv kör jag dvdlink. Det comhem gjort är att ändra QAM från 64 till 256 vilket jag var tvungen att gå in och ändra i en .ini fil för att få dvdlink att hitta kanalerna. Vet som sagt inte hur MythTV fungerar men tänkte det kunde vara ett tips iaf.

/Roger

#3

Skickat 05 mars 2012 - 18:10

Har provat att ändra till QAM256, fast det hjälper inte.
Har scannat på alla sätt jag kan komma på utan att det hjälper.
Jämför jag med uppgifterna på http://www.lesve.org/digtv/service/, så är det bla kanalerna 290Mhz som jag saknar.

Fler idéer?


#4

Skickat 05 mars 2012 - 20:05

Jag skapade följande fil för verktyget scan i linux:
C 290000000 6875000 NONE QAM64
C 298000000 6875000 NONE QAM64
C 306000000 6875000 NONE QAM64
C 314000000 6875000 NONE QAM64
C 322000000 6875000 NONE QAM64
C 330000000 6875000 NONE QAM64
C 338000000 6875000 NONE QAM64
C 346000000 6875000 NONE QAM64
C 354000000 6875000 NONE QAM64
C 362000000 6875000 NONE QAM64
C 370000000 6875000 NONE QAM64
C 378000000 6875000 NONE QAM64
C 386000000 6875000 NONE QAM64
C 394000000 6875000 NONE QAM64
C 402000000 6875000 NONE QAM64
C 410000000 6875000 NONE QAM64
C 418000000 6875000 NONE QAM64
C 426000000 6875000 NONE QAM64
C 434000000 6875000 NONE QAM64
C 442000000 6875000 NONE QAM64
C 450000000 6875000 NONE QAM64
C 458000000 6875000 NONE QAM64
C 466000000 6875000 NONE QAM64
C 474000000 6875000 NONE QAM64
C 482000000 6875000 NONE QAM64
C 490000000 6875000 NONE QAM64
C 498000000 6875000 NONE QAM64
C 290000000 6875000 NONE QAM256
C 298000000 6875000 NONE QAM256
C 306000000 6875000 NONE QAM256
C 314000000 6875000 NONE QAM256
C 322000000 6875000 NONE QAM256
C 330000000 6875000 NONE QAM256
C 338000000 6875000 NONE QAM256
C 346000000 6875000 NONE QAM256
C 354000000 6875000 NONE QAM256
C 362000000 6875000 NONE QAM256
C 370000000 6875000 NONE QAM256
C 378000000 6875000 NONE QAM256
C 386000000 6875000 NONE QAM256
C 394000000 6875000 NONE QAM256
C 402000000 6875000 NONE QAM256
C 410000000 6875000 NONE QAM256
C 418000000 6875000 NONE QAM256
C 426000000 6875000 NONE QAM256
C 434000000 6875000 NONE QAM256
C 442000000 6875000 NONE QAM256
C 450000000 6875000 NONE QAM256
C 458000000 6875000 NONE QAM256
C 466000000 6875000 NONE QAM256
C 474000000 6875000 NONE QAM256
C 482000000 6875000 NONE QAM256
C 490000000 6875000 NONE QAM256
C 498000000 6875000 NONE QAM256
Den är baserad på denna fil för dreambox: cables.xml som jag hittade på följande forumtråd.
Kopiera innehållet ovan och sparar till en fil lokalt t.ex. se_comhem. Kör sedan scan från denna fil:
scan se_comhem > scan.conf
Nu hittar du förhoppningsvis lite fler kanaler. Från mythtv-setup kan du använda scan.conf för importera kanalerna.

Edit: Uppdaterade listan utifrån följande: http://www.lesve.org/digtv/service/

Det här inlägget har ändrats av sebulator 06 mars 2012 - 11:17


#5

Skickat 10 mars 2012 - 10:35

Har också stora problem att hitta kanaler. Lite olika beroende på när och hur jag söker. Men just nu hittar jag t.ex. inte SVT 1 HD, Svt 2 HD, Axess, TCM och Kanal 9 plus lite smått och gott.

Extremt konstigt och frustrerande. Om jag testar att skriva in att den ska söka en speciell frekvens, ja då hittar den inga kanaler, men om den ska söka via import av channels.conf, då hittar den vissa.

Hittade en väg runt. Om man lägger till frekvenser manuellt, så funkar det. Lite pill men löser problemet med att man inte hittar kanaler vid "vanlig" sökning.

Däremot kvarstår mitt andra problem, att vissa kanaler är väldigt jiddriga att titta på.

Det här inlägget har ändrats av frippes 10 mars 2012 - 12:39


#6

Skickat 10 mars 2012 - 14:26

Detta var ett irriterande problem att lösa... har försökt köra scan nu i några timmar men går inite bra alls. är det någon som har en channels.conf fil man kan få titta på för att se vad resultatet ska bli i slutendan.

#7

Skickat 12 mars 2012 - 09:56

Visa inläggBjorneweb 10 mars 2012 - 14:26 skrev:

Detta var ett irriterande problem att lösa... har försökt köra scan nu i några timmar men går inite bra alls. är det någon som har en channels.conf fil man kan få titta på för att se vad resultatet ska bli i slutendan.
Provade du att köra scan på det sättet jag beskrev ovan? Jag bifogar en scan.conf som en sådan scanning producerar för mig. Jag misstänker att den conf-filen inte funkar för alla, det skiljer sig i olika delar av landet och du måste antagligen göra din egen scan. Prova att köra så som jag beskrev tidigare i tråden så får du en egen som funkar för dig.

Bifogade fil(er)



#8

Skickat 20 mars 2012 - 18:43

Körde en scan med sebulatos lista ovan och då hittar jag alla kanalerna. Tackar!

Tog sedan och läste in kanaler i mythtv baserat på channels.conf.

Kanalerna kommer in, men när jag vill spela in/titta på TV6 så blir det inget. Någon idé om vad som kan vara fel?

#9

Skickat 06 maj 2012 - 10:55

Hej,
Jag har fått TV6 att fungera genom att göra en kanalsökning av typen "full sökning, justerad" och mata in frekvensen 290000000 och vrida ned symbolhastighet till 6875000.
Jag har dock inte lyckats få till det med några betalkanaler efter omläggningen (jag har ett Twinhan cab-ci kort (VP2031a) med conax modul). Jag får meddelanden av den här typen i mythbackends log:


May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1032) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1097) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1031) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1099) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1098) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1160) desired(1107)
May 6 11:21:14 mythbox5 mythbackend[8519]: E DVBRead dtvsignalmonitor.cpp:347 (HandlePMT) DTVSM(/dev/dvb/adapter
0/frontend0): Wrong PMT; pmt->pn(1012) desired(1107)

Kanalsökningen ställer inte in det nätverksid som comhem säger att det skall vara. Jag har provat att ändra (via SQL i databasen), men det har inte gjort någon skillnad.
Förslag?

#10

Skickat 06 maj 2012 - 17:07

Jag skulle tro att patchen i http://code.mythtv.o...rac/ticket/7486 skulle hjälpa.

Om ni MythTV kompilerar själv kan ni prova att göra en ny kanalsökning efter att ha lagt på patchen.

För 0.24:
http://code.mythtv.o...with_gui.2.diff

För 0.25:
http://code.mythtv.o...with_gui.3.diff


Jag har inte kollat hur mycket koden har ändrats i 0.24 eller 0.25 sedan patcharna gjordes, så eventuellt kan man bli tvungen göra ändringarna manuellt.

#11

Skickat 23 maj 2012 - 20:07

Jag får inte detta att fungera, känns som att jag provat allt!

Gör jag en vanlig kanalsökning hittar jag ca. 45 kanaler mot normalt 175.
Söker jag kanaler med hjälp av frekvens får jag fram alla kanaler, men de kodade fungerar inte.
Uppgraderade då Ubuntu från 10.10 till 11.10 och byggde fixes/0.25 från source, ingen skillnad.
Installerade patcharna ovan, anger NetID 41001 (ComHem Stockholm), ingen skillnad.

I loggen får jag massor med "Wrong PMT; pmt->pn(XXXX) desired (XXXX)"

Använder ett Technotrend C1501 med tillhörande CI, aldrig varit några problem tidigare.

Vad gör jag?

EDIT: När jag kollar transporterna i mythtv-setup är alla inställda på netid 40999 trots att jag alltså valt 41001 under video sources?

Det här inlägget har ändrats av Oxygen 23 maj 2012 - 20:24


#12

Skickat 25 maj 2012 - 07:17

Nu vet inte jag om det är ett generellt problem, men jag hade ett Technotrend C1500 innan, vilket skapade väldigt stora problem med kvalité på signalmottagningen och problem med att hitta kanaler. Både före och efter kanalomläggningen. Kortet funkade klockrent till en början (2008) men blev sämre och sämre med tiden. För att nu i bli omöjlig att få att fungera klockrent. Vart felet ligger i förhållande till Technotrend har jag ingen aningen om, drivrutiner eller något annat kanske.

Bytte till ett annat kort jag har hemma och alla problem försvann. Nu funkar alla kanaler, de hittas lätt och har extremt bra kvalité på bild. Nu fattas bara att få igång softcam för de kodade kanalerna.

Bytte till ett FireDTV, föresten.

#13

Skickat 28 maj 2012 - 17:20

Fick igång det med TVHeadend, OSCam och en bankdosa från Nordea!

Efter att ha kört MythTV i 7-8 år fick denna kanalomläggning mig att byta till TVHeadend!

#14

Skickat 11 juni 2012 - 10:20

Jag har 2st nexus-ca och 1st anysee.
Efter att ha skiftat antennsladdar och scannat mm,
har jag kommit fram till att efter att ha läst på dvs mailinglistor att det är koden i stv0297.c frontenden som nexus-korten använder som är kajko på QAM256.
QAM64 funkar fortfarande bra med svt1,2, tv4. Medans betalkanaler och svt-hd* inte låser.
Anysee kortet har inget problem med scanningen eller att visa alla kanaler, medans nexus korten inte kan låsa på dom kanaler Anysee kortet scannat.
Så att byta till någon annan programvara hjälper inte i mitt fall. Men att byta till Windows skulle funka, men det är ju inget alternativ för mig.

#15

Skickat 13 juni 2012 - 11:33

Hmm, konstigt, försöker precis få igång en nyinstallation av Myth med ett FireDTV kort för DVB-C. Har också stora problem med att få alla kanaler på QAM-256 att funka bra. Oavsett om jag scannar med Myths egna eller kör en channel.conf.

Undrar hur det kan komma sig?

#16

Skickat 14 juni 2012 - 13:40

Jag har fixat mina kort. Samma kan säkert lösa problem med andra kort.
--------------
diff -ru v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.c v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.c
--- v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.c 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.c 2008-07-26 18:16:38.000000000 +0200
@@ -463,7 +463,9 @@
stv0297_writereg(state, 0x82, 0x0);

/* set initial demodulation frequency */
- stv0297_set_initialdemodfreq(state, 7250);
+ stv0297_set_initialdemodfreq(state,
+ state->config->qam256_reduced_demodfreq &
+ (p->modulation == QAM_256) ? 6718 : 7250);

/* setup AGC */
stv0297_writereg_mask(state, 0x43, 0x10, 0x00);
diff -ru v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.h v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.h
--- v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.h 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.h 2008-07-26 18:16:38.000000000 +0200
@@ -40,6 +40,11 @@

/* set to 1 if the device requires an i2c STOP during reading */
u8 stop_during_read:1;
+
+ /* set to 1 if the device requires reduced demodulation frequency
+ * for QAM256.
+ */
+ u8 qam256_reduced_demodfreq:1;
};

#if defined(CONFIG_DVB_STV0297) || (defined(CONFIG_DVB_STV0297_MODULE) && defined(MODULE))
diff -ru v4l-dvb.org/linux/drivers/media/dvb/ttpci/av7110.c v4l-dvb/linux/drivers/media/dvb/ttpci/av7110.c
--- v4l-dvb.org/linux/drivers/media/dvb/ttpci/av7110.c 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/ttpci/av7110.c 2008-07-26 18:16:38.000000000 +0200
@@ -1874,6 +1874,7 @@
.inittab = nexusca_stv0297_inittab,
.invert = 1,
.stop_during_read = 1,
+ .qam256_reduced_demodfreq = 1,
};


diff -ru v4l-dvb.org/linux/drivers/media/dvb/ttpci/budget-ci.c v4l-dvb/linux/drivers/media/dvb/ttpci/budget-ci.c
--- v4l-dvb.org/linux/drivers/media/dvb/ttpci/budget-ci.c 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/ttpci/budget-ci.c 2008-07-26 18:16:38.000000000 +0200
@@ -1061,6 +1061,7 @@
.inittab = dvbc_philips_tdm1316l_inittab,
.invert = 0,
.stop_during_read = 1,
+ .qam256_reduced_demodfreq = 0,
};

static struct tda10023_config tda10023_config = {
diff -ru v4l-dvb.org/linux/drivers/media/dvb/ttusb-budget/dvb-ttusb-budget.c v4l-dvb/linux/drivers/media/dvb/ttusb-budget/dvb-ttusb-budget.c
--- v4l-dvb.org/linux/drivers/media/dvb/ttusb-budget/dvb-ttusb-budget.c 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/ttusb-budget/dvb-ttusb-budget.c 2008-07-26 18:16:38.000000000 +0200
@@ -1572,6 +1572,7 @@
.demod_address = 0x1c,
.inittab = dvbc_philips_tdm1316l_inittab,
.invert = 0,
+ .qam256_reduced_demodfreq = 0,
};

static void frontend_init(struct ttusb* ttusb)
--------------------
Det är dessa futtiga rader som gör skillnaden. Motsvarande finns säkert för andra frontends.
diff -ru v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.c v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.c
--- v4l-dvb.org/linux/drivers/media/dvb/frontends/stv0297.c 2008-07-26 18:14:23.000000000 +0200
+++ v4l-dvb/linux/drivers/media/dvb/frontends/stv0297.c 2008-07-26 18:16:38.000000000 +0200
@@ -463,7 +463,9 @@
stv0297_writereg(state, 0x82, 0x0);

/* set initial demodulation frequency */
- stv0297_set_initialdemodfreq(state, 7250);
+ stv0297_set_initialdemodfreq(state,
+ state->config->qam256_reduced_demodfreq &
+ (p->modulation == QAM_256) ? 6718 : 7250);


/* setup AGC */

Mvh Fredrik

Det här inlägget har ändrats av shade73a 14 juni 2012 - 13:41


#17

Skickat 18 juni 2012 - 16:11

Visa inläggshade73a 14 juni 2012 - 13:40 skrev:

Jag har fixat mina kort. Samma kan säkert lösa problem med andra kort.
--------------

/* setup AGC */

Mvh Fredrik

Var ändrar du detta?

#18

Skickat 19 juni 2012 - 09:41

I kernel sourcen. I mitt fall stv0297.c

Jag läste att en firmware uppgradering (1.2.7) skulle lösa QAM256 problem för FIREDTV, sen om det avser en firmware eller en drivrutin för Windows vet jag inte.




1 användare läser den här tråden

Medlemmar: 0 - Gäster: 1 - Anonyma användare: 0

Detta forum sponsras av
  • Monster Lås!
    dac83
    2014-10-24 20:58:16
  • Knappt ngn upgrade :-P
    Degpojken
    2014-10-24 18:18:34
  • Svårflyttade väger bly
    Degpojken
    2014-10-24 18:17:17
  • Shiny
    Degpojken
    2014-10-24 18:14:40
  • Wiee
    Degpojken
    2014-10-24 18:11:15
  • Fler  |  Vilka bilder visas här?
Prisjakt © 2000 - 2014 Prisjakt   Denna sajt använder cookies.   Våra regler.