Hoppa till innehåll

Sökresultat Sökningen pågår Sökresultaten dyker upp här efterhand. Du kan fortsätta skriva om du vill begränsa sökningen.
Söker efter filmer
Söker efter produktkategorier
Söker efter användare
Söker efter gallerier
Sök forumtrådar
Stäng

VPN klient genom ASUS RT-N66U - önskar hjälp!

9 svar i tråden

#1

Skickat 05 april 2012 - 08:23

Hejsan alla,
Som trådrubriken visar har jag införskaffat en ny router, men dykt på problem direkt. Jag behöver ibland jobba hemifrån och då måste jag använda en specifik VPN-klient för att ansluta mot företaget. Klienten är Cisco VPN client 5.0.04.0300. Kan även nämna att jag testat att koppla förbi routen och då fungerar VPN-tunneln som den ska. I klienten kan jag göra ett par inställningar, bl.a. någon inställning om "transporten". Där finns ett val som aktiverar: transparent tunneling. Om jag aktiverar det kan jag i sin tur välja att köra aningen:
* IPSec over UDP (NAT/PAT) eller
* IPSec over TCP, TCP port: 10000.
Väljer jag att försöka ansluta utan att först valt "aktivera transparent tunneling" eller att jag aktiverar det och sedan väljer IPSec over UDP, skapas en anslutning, men ingen trafik kommer igenom. Kör jag transparent tunneling med IPSec over TCP får jag efter en stund ett felmeddelande "failed to establish ā TCP connection.
Är det någon som har några tips på vad jag ska ställa in i routern, och isåfall hur. Jag kör med mjukvara 3.0.0.3.108 i routern.
Väldigt tacksam för alla tips!

#2

Skickat 05 april 2012 - 08:55

Det bästa är om du kan köra TCP då det fungerar betydligt smidigare genom din routers adressöversättning. Tyvärr är det inte påslaget med automatik i din arbetsgivares utrustning (i alla fall inte om den är lite äldre i VPN3000-serien och det är väl det troligaste, hade det varit en ASA5000-någonting hade ni kört AnyConnect-klienten) så det är inte säkert att det fungerar. Det du kan göra är att prova TCP-port 20000, jag har sett flera som kör UDP på 10000 och TCP på 20000. Fungerar inte det heller får du prata med rätt personer på företaget för att kolla hur det är uppsatt.

#3

Skickat 05 april 2012 - 09:19

Visa inläggSwedXit 05 april 2012 - 08:23 skrev:

Hejsan alla,
Som trådrubriken visar har jag införskaffat en ny router, men dykt på problem direkt. Jag behöver ibland jobba hemifrån och då måste jag använda en specifik VPN-klient för att ansluta mot företaget. Klienten är Cisco VPN client 5.0.04.0300. Kan även nämna att jag testat att koppla förbi routen och då fungerar VPN-tunneln som den ska. I klienten kan jag göra ett par inställningar, bl.a. någon inställning om "transporten". Där finns ett val som aktiverar: transparent tunneling. Om jag aktiverar det kan jag i sin tur välja att köra aningen:
* IPSec over UDP (NAT/PAT) eller
* IPSec over TCP, TCP port: 10000.
Väljer jag att försöka ansluta utan att först valt "aktivera transparent tunneling" eller att jag aktiverar det och sedan väljer IPSec over UDP, skapas en anslutning, men ingen trafik kommer igenom. Kör jag transparent tunneling med IPSec over TCP får jag efter en stund ett felmeddelande "failed to establish à TCP connection.
Är det någon som har några tips på vad jag ska ställa in i routern, och isåfall hur. Jag kör med mjukvara 3.0.0.3.108 i routern.
Väldigt tacksam för alla tips!

Koilla efter IPSec Pass-Throuth i routern.

#4

Skickat 05 april 2012 - 12:46

Är rätt säker på att både TCP och UDP kommunikation fungerar med VPN-servern så länge det inte är via min router, dvs när jag kör direkt via min fiberkonverters WAN-port. Iom detta så vet jag att problemet är hos mig och i routern. Jag har även tittat efter och sett att IPSec genompassering är aktiverat i routern. Fler tips?

#5

Skickat 05 april 2012 - 14:14

Eftersom du kör en Cisco VPN klient så kan man väl bara gissa att det sitter en Cisco ASA som end-point för VPN tunneln på ditt jobb.

Har stött på en bugg som gör att följande rad dyker upp:


no crypto isakmp nat-traversal

i configurationen. Kolla om den finns, gör den det så fungerar inte VPN om du sitter bakom en NAT:ad adress vilket du gör.

#6

Skickat 05 april 2012 - 15:55

Ursäkta en idiotfråga, men du menar i konfigurationen på VPN-servern väl? .... ;-)

Det här inlägget har ändrats av SwedXit 05 april 2012 - 16:25


#7

Skickat 05 april 2012 - 19:57

Japp, exakt. Sorry om jag var lite oklar.

#8

Skickat 10 april 2012 - 08:04

Tydligen kör företaget en föregångare till Cisco ASA, som heter något med "koncentrator". Tror du denna bugg även kan finnas här?

#9

Skickat 10 april 2012 - 20:21

Med största sannolikhet en VPN-koncentrator i VPN3000-serien, vi har ett par som skrotar kvar på jobbet. Har du verifierat att TCP fungerar bra när du kopplar förbi routern och går direkt på WAN-porten i fiberlådan? TCP-trafiken brukar inte ha problem att ta sig igenom adressöversättningen i vanliga hemmaroutrar.

#10

Skickat 11 april 2012 - 17:32

Japp, utan router fungerar det fint med tcp och Cisco servern.

Vet att de har en annan VPN server och klient som kommit efter Cisco versionen, så det blir till att försöka få den installerad istället och se om det fungerar bättre. I övrigt har jag inte haft några problem med denna routern så jag hoppas att problemet ligger hos Cisco :-)





1 användare läser den här tråden

Medlemmar: 0 - Gäster: 1 - Anonyma användare: 0

Detta forum sponsras av
  • Raspberry pi Ambilight
    CusmaR
    2014-11-21 22:19:02
  • gröten
    2014-11-21 22:13:48
  • Fronten äntligen klar.
    cyanid
    2014-11-21 20:46:44
  • My Darling Clementine (1946), La Dolce Vita (1960), The Vanishing (1988), F For Fake (1975)
    sajbot
    2014-11-21 12:49:39
  • The Complete Jacques Tati (1949-1974)
    sajbot
    2014-11-21 12:46:20
  • Fler  |  Vilka bilder visas här?
Prisjakt © 2000 - 2014 Prisjakt   Denna sajt använder cookies.   Våra regler.